počet výskytů textů

Programy pro práci v kanceláři (Word, Excel, Access…=>Office)

Moderátor: Mods_senior

dikinak
nováček
Příspěvky: 6
Registrován: leden 13
Pohlaví: Muž

počet výskytů textů

Příspěvekod dikinak » 09 úno 2021 23:01

Ahoj všem,
řeším už několikátý den jeden záludný vyhledávací a součtový problém v tabulce viz. příloha.
test.xlsx

Mám seznam zemí (který je zcela proměnný), a potřebuji jednoduše sečíst kolikrát jsou tam jednotlivé země (podle tří skupin).
První skupina je CZ - toto je jednoduché.
Druhá skupina jsou vybrané země - tady bych to vyřešit podobně, jako s CZ jen bych tam dal jednotlivé země a sečetl (něco takového =COUNTIF(země!A:A;"HU")+COUNTIF(země!A:A;"SK")+COUNTIF(země!A:A;"DE")+COUNTIF(země!A:A;"IT")+... atd.
Třetí skupina je vše ostatní, ale zde může být defakto cokoliv co není ve výše uvedeném. Ale toto fakt nevím, jak to vyhledat.

Napadne někoho nějaké jednoduché, ale funkční řešení?

Děkuji mnohokráte za nápady!
Nemáte oprávnění prohlížet přiložené soubory.



Reklama
Uživatelský avatar
elninoslov
Level 2.5
Level 2.5
Příspěvky: 284
Registrován: červen 13
Pohlaví: Muž

Re: počet výskytů textů

Příspěvekod elninoslov » 10 úno 2021 00:35

SK

Kód: Vybrat vše

=COUNTIFS(země!A2:A350;"CZ")
=SUM(--IFERROR(SEARCH(","&země!A2:A350&",";","&A4&",")>0;FALSE))
=SUM(--ISERROR(SEARCH(","&země!A2:A350&",";","&A3&","&A4&",")))

CZ

Kód: Vybrat vše

=COUNTIFS(země!A2:A350;"CZ")
=SUMA(--IFERROR(HLEDAT(","&země!A2:A350&",";","&A4&",")>0;NEPRAVDA))
=SUMA(--JE.CHYBHODN(HLEDAT(","&země!A2:A350&",";","&A3&","&A4&",")))
Naposledy upravil(a) elninoslov dne 10 úno 2021 13:49, celkem upraveno 1 x.

dikinak
nováček
Příspěvky: 6
Registrován: leden 13
Pohlaví: Muž

Re: počet výskytů textů

Příspěvekod dikinak » 10 úno 2021 09:27

Děkuji moc za návrh řešení.

Nevím co dělám špatně, ale =SUMA(--IFERROR(HLEDAT(","&země!A2:A350&",";","&A4&",")>0;NEPRAVDA)) mi vrací 0.
a
=SUMA(--ISERROR(HLEDAT(","&země!A2:A350&",";","&A3&","&A4&","))) - my vrací chybu v názvu.

Co dělám špatně?

Uživatelský avatar
elninoslov
Level 2.5
Level 2.5
Příspěvky: 284
Registrován: červen 13
Pohlaví: Muž

Re: počet výskytů textů

Příspěvekod elninoslov » 10 úno 2021 13:49

Tie 2 vzorce so SUM/SUMA sú maticové, teda sa nezadávajú cez Enter, ale cez Ctrl + Shift + Enter.
V tom poslednom som zabudol preložiť do češtiny ISERROR - > JE.CHYBHODN.

Dalo by sa aj nematicovo, ale musí byť isté, že nejaký kód krajiny nebude zároveň časťou kódu inej napr CRO a RO. Ak sú všetky 2 znakové, tak to je v poho.
SK

Kód: Vybrat vše

=SUMPRODUCT(--(COUNTIF(A4;"*"&země!A2:A350&"*")>0))
=SUMPRODUCT(--(COUNTIF(A3;"*"&země!A2:A350&"*")+COUNTIF(A4;"*"&země!A2:A350&"*")=0))


CZ

Kód: Vybrat vše

=SOUČIN.SKALÁRNÍ(--(COUNTIF(A4;"*"&země!A2:A350&"*")>0))
=SOUČIN.SKALÁRNÍ(--(COUNTIF(A3;"*"&země!A2:A350&"*")+COUNTIF(A4;"*"&země!A2:A350&"*")=0))

dikinak
nováček
Příspěvky: 6
Registrován: leden 13
Pohlaví: Muž

Re: počet výskytů textů

Příspěvekod dikinak » 10 úno 2021 16:19

Super díky moc!

Funguje a problém vyřešen :)


  • Mohlo by vás zajímat
    Odpovědi
    Zobrazení
    Poslední příspěvek
  • jak vyhledat v databázi počet odpovědí z fóra
    od Martin Baroch » 08 dub 2021 21:16 » v Vše ostatní (sw)
    10
    231
    od Martin Baroch
    09 dub 2021 01:44
  • Jak nastavit limit na počet přistupů na webovou stránku?
    od Daminekkkk » 29 srp 2020 14:29 » v Vše ostatní (hw)
    0
    408
    od Daminekkkk
    29 srp 2020 14:29
  • Program pro vyhledávání a nahrazování textu
    od martanius » 08 dub 2021 14:21 » v Vše ostatní (sw)
    4
    157
    od faraon
    08 dub 2021 21:12
  • Automatické vkládání textu Word 2016
    od Rockym » 24 srp 2020 11:04 » v Kancelářské balíky
    3
    761
    od Grimm
    01 led 2021 01:56
  • Podmíněné formátování - změna textu buňky
    od HaTo » 13 led 2021 12:50 » v Kancelářské balíky
    2
    352
    od HaTo
    13 led 2021 19:07

Zpět na “Kancelářské balíky”

Kdo je online

Uživatelé prohlížející si toto fórum: CommonCrawl [Bot] a 1 host