Excel - podmíněné formátování s VLOOKUP Vyřešeno

Programy pro práci v kanceláři (Word, Excel, Access…=>Office)

Moderátor: Mods_senior

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 255
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Excel - podmíněné formátování s VLOOKUP

Příspěvekod metropolisCZ » 20 lis 2020 17:18

Ahoj,

prosím, potřebuji poradit s podmíněným formátováním s využitím vzorce - v tom případě VLOOKUP.
V příloze je příklad - Sheet 1 obsahuje tři řádky s hodnotami, které by se měly žlutě zvýraznit v případě, že tyto hodnoty mají "0" v druhém sloupci na Sheetu 2. Něco mám určitě špatně, protože to nefunguje. :-)

Předem díky moc za radu.
Nemáte oprávnění prohlížet přiložené soubory.


GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10

Reklama
MePExG
Level 2
Level 2
Příspěvky: 193
Registrován: srpen 16
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod MePExG » 20 lis 2020 19:25

Ten vzorec bol nefunkčný (v podmienenom formáte), lebo bol uzavretý v apostrofoch, alebo uvodzovkách. ...a čo prípad, ak hodnotu nenájde?
Nemáte oprávnění prohlížet přiložené soubory.

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 255
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod metropolisCZ » 20 lis 2020 20:40

Já jsem ten vzorec psal bez uvozovek, ale Excel si je tam z nějakého důvodu doplnil. Každopádně díky - nicméně teď zkouším, jestli vzorec funguje i s pojmenovanou/definovanou oblastí. Na Sheetu 2 jsem oblast zadal jako Table1. Když to pak zkouším zadat do vzorce, zase mi to píše chybu.

Když hodnotu nenajde neřeším, vždy tam bude, tohle je pouze příklad.

Test_cond_form_Excel.png
Nemáte oprávnění prohlížet přiložené soubory.
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 255
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod metropolisCZ » 23 lis 2020 09:02

up
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10

cmuch
Level 4.5
Level 4.5
Příspěvky: 1529
Registrován: březen 11
Bydliště: Drsná Vysočina :D
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod cmuch » 23 lis 2020 11:57

Urav vzorec na =SVYHLEDAT($B3;Table1[#Vše];2;0)=0 / =VLOOKUP($B3;Table1[#All];2;0)=0

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 255
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod metropolisCZ » 23 lis 2020 15:42

cmuch píše:Urav vzorec na =SVYHLEDAT($B3;Table1[#Vše];2;0)=0 / =VLOOKUP($B3;Table1[#All];2;0)=0


Bohužel to nefunguje - stále stejná chybová hláška.
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 255
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod metropolisCZ » 25 lis 2020 10:23

Napadá někoho ještě něco, prosím?
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10

MePExG
Level 2
Level 2
Příspěvky: 193
Registrován: srpen 16
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod MePExG » 25 lis 2020 10:59

Podmienený formát nepodporuje odkazy na tabuľky. Buď si vytvorte stĺpec so vzorcom vyhľadania z tabuľky a na výsledok sa odvolajte v podmienenom formáte, alebo odkazujte na rozsah.

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 255
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP  Vyřešeno

Příspěvekod metropolisCZ » 25 lis 2020 12:50

OK, díky za jasnou odpověď. Nechám to tedy tak, jak to mám - odkaz na rozsah. Vlákno zamykám.
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10


  • Mohlo by vás zajímat
    Odpovědi
    Zobrazení
    Poslední příspěvek
  • Podmíněné formátování - změna textu buňky
    od HaTo » 13 led 2021 12:50 » v Kancelářské balíky
    2
    97
    od HaTo
    13 led 2021 19:07
  • Podmíněné připojení k netu (W10)
    od pl4toon » 13 bře 2020 13:02 » v Administrace sítě
    10
    1301
    od kecalek
    13 bře 2020 19:49
  • Excel VBA
    od Bobo799 » 09 pro 2020 11:22 » v Kancelářské balíky
    3
    275
    od elninoslov
    09 led 2021 11:43
  • Excel - vzoreček
    od SmejkalM » 18 bře 2020 07:33 » v Vše ostatní (sw)
    6
    1123
    od elninoslov
    20 bře 2020 13:18
  • makro excel
    od pajdaj » 08 dub 2020 09:09 » v Kancelářské balíky
    4
    727
    od pajdaj
    09 dub 2020 07:24

Zpět na “Kancelářské balíky”

Kdo je online

Uživatelé prohlížející si toto fórum: CepiniusCZ, CommonCrawl [Bot] a 1 host