Excel - sčítat dle dvou kriterií - ale ne Sumifs Vyřešeno

Programy pro práci v kanceláři (Word, Excel, Access…=>Office)

Moderátor: Mods_senior

Pohis
nováček
Příspěvky: 5
Registrován: březen 20
Pohlaví: Muž

Excel - sčítat dle dvou kriterií - ale ne Sumifs

Příspěvekod Pohis » 19 úno 2021 07:00

Ahoj,
je možné v excelu sčítat hodnoty dle dvou kritérií, ale která nejsou ve sloupcích, ale ve sloupci a řádku?

Tzn., ve sloupci A jsou např. "jména", v řádku 2 třeba "názvy něčeho".
Potřebuji z jiných dvou tabulek, kde jsou ale "názvy něčeho" v jiných různých sloupcích, najít dle jména a určitého "názvu něčeho" sečíst, Raději příklad viz. příloha.
Nemáte oprávnění prohlížet přiložené soubory.



Reklama
Uživatelský avatar
elninoslov
Level 2.5
Level 2.5
Příspěvky: 280
Registrován: červen 13
Pohlaví: Muž

Re: Excel - sčítat dle dvou kriterií - ale ne Sumifs  Vyřešeno

Příspěvekod elninoslov » 19 úno 2021 08:04

Kód: Vybrat vše

=SUMPRODUCT(($B$10:$G$10=B$2)*($A$11:$A$14=$A3);$B$11:$G$14)+SUMPRODUCT(($B$17:$G$17=B$2)*($A$18:$A$21=$A3);$B$18:$G$21)
=SOUČIN.SKALÁRNÍ(($B$10:$G$10=B$2)*($A$11:$A$14=$A3);$B$11:$G$14)+SOUČIN.SKALÁRNÍ(($B$17:$G$17=B$2)*($A$18:$A$21=$A3);$B$18:$G$21)
Nemáte oprávnění prohlížet přiložené soubory.


  • Mohlo by vás zajímat
    Odpovědi
    Zobrazení
    Poslední příspěvek
  • Funkce Sumifs mě nechce vzít datum vložené makrem
    od luko02420 » 31 črc 2020 08:42 » v Kancelářské balíky
    2
    746
    od luko02420
    31 črc 2020 13:36
  • Porovnání dvou ntb
    od helpmeboys » 13 říj 2020 12:06 » v Rady s výběrem hardwaru a sestavením PC
    1
    184
    od petr22
    13 říj 2020 12:29
  • výběr ze dvou sestav
    od lukas___5 » 20 říj 2020 22:19 » v Rady s výběrem hardwaru a sestavením PC
    2
    196
    od xbs
    20 říj 2020 22:28
  • Výběr dvou routerů
    od -danda- » 19 říj 2020 15:58 » v Sítě - hardware
    5
    515
    od ITCrowd
    21 říj 2020 23:59
  • Výběr ze dvou PC sestav
    od lukas___5 » 14 říj 2020 19:42 » v Rady s výběrem hardwaru a sestavením PC
    1
    230
    od petr22
    14 říj 2020 19:44

Zpět na “Kancelářské balíky”

Kdo je online

Uživatelé prohlížející si toto fórum: CommonCrawl [Bot] a 0 hostů